PiHole macht bei FritzBox Probleme

29 Dec 2017
243
26
#1
Hey, hab mir nen Raspberry Pi 3 gekauft um mir das PiHole einzurichten. Leider funktioniert das nicht so wie gewollt. Ich habe das PiHole auf dem Pi installiert, lief alles super. Danach habe ich in meiner Fritz Box 6591 Cable von Unitymedia unter "Heimnetzwerk -> Zugangsart -> DNS Server -> Bevorzugter/Alternativer DNS Server verwenden" meine IPv4 Adresse vom Pi eingetragen. Das PiHole funktioniert, jedoch nicht an allen geräten. An meinem Handy bspw läuft alles super, Werbung wird geblockt, alles gut. Jedoch bekommt mein PC und das Handy meiner Freundin gar kein Internet mehr. Ich habe einen Fritz Repeater 1750E im Haus an dem ist mein PC per LAN dran. Komischerweise funktioniert bei mir am PC nur Firefox, bzw bekommt nur Firefox Internet. Der rest der Anwendungen bekommt kein Internet. Ich bin echt ratlos, vielleicht hatte jemand mal ein ähnliches Problem und kann weiterhelfen.
 
29 Dec 2017
243
26
#3
Einfach in der FB den DNS von google oder cloudflare behalten und im PiHole dann Upstream auf die FB und "Listen on all interfaces".

Okay, jetzt ist mein PiHole so eingestellt wie im Screenshot. In der FritzBox habe ich jetzt sodass mein Internet wenigstens wieder funktioniert die DNS Einstellungen wieder auf Standardmäßig gemacht. Was muss ich jetzt noch in der FB einstellen? Normalerweise ist ja so, dass ich dann als DNS Server die IPv4 vom PiHole verwende. Jetzt soll ich da den DNS von Google/Cloudflare eintragen? Oder wie ist das gemeint?
 
26 Mar 2015
2,240
3,266
#4
Okay, jetzt ist mein PiHole so eingestellt wie im Screenshot. In der FritzBox habe ich jetzt sodass mein Internet wenigstens wieder funktioniert die DNS Einstellungen wieder auf Standardmäßig gemacht. Was muss ich jetzt noch in der FB einstellen? Normalerweise ist ja so, dass ich dann als DNS Server die IPv4 vom PiHole verwende. Jetzt soll ich da den DNS von Google/Cloudflare eintragen? Oder wie ist das gemeint?
Du hast somit alles getan. Solltest du auch sehen wenn du jetzt in dein PiHole schaust dass er von allen Devices den DNS übernimmt. DNS von google/cloudflare KANNST du eintragen, musst du aber nicht. Sind aber definitiv schneller als der von UM^^

 
Likes: Krampus3310
29 Dec 2017
243
26
#5
Du hast somit alles getan. Solltest du auch sehen wenn du jetzt in dein PiHole schaust dass er von allen Devices den DNS übernimmt. DNS von google/cloudflare KANNST du eintragen, musst du aber nicht. Sind aber definitiv schneller als der von UM^^


Habe jetzt in meiner FB als Alternativer/Primärer DNS 8.8.8.8 & 8.8.4.4 eingetragen. Diesmal funktioniert das Internet. Im PiHole unter Network sieht das so aus wie bei dir im Screenshot. Kenne mich noch nicht so mit dem PiHole aus, aber ich sehe keine Werbung mehr unter allen Geräten. Jedoch steigt nicht die Zahl im PiHole Dashboard bei "Queries" sondern bei "Total Queries". Ich denke jetzt mal "Queries" zeigt die geblockten Ads an, bei welchem das PiHole Interface gerade in Benutzung ist (in meinem Fall mein Computer) und total Queries, die geblockten Ads von allen geräten, oder liege ich da falsch? Ich glaube das funktioniert nun, besten dank. Achja und ich wollte die Pihole Liste von SemperVideo in mein PiHole eintragen (https://raw.githubusercontent.com/RPiList/specials/master/notserious) ich gehe da auf mein PiHole Interface klicke auf Settings -> BlockLists und trage da die URL ein und klicke auf Save & Update. Komischerweise komme ich danach immer noch auf die Webseiten die eigentlich geblockt werden müssten laut der Liste. Mache ich da was falsch? :grin:
 
Last edited:
26 Mar 2015
2,240
3,266
#11
Kenne mich noch nicht so mit dem PiHole aus, aber ich sehe keine Werbung mehr unter allen Geräten.
Du hast doch hier selbst bestätigt dass es funktioniert. Wenn jetzt eine Seite doch Werbung anzeigt deckt deine Liste es wohl nicht ab.

Empfehle dir auch dich einfach mal in das Thema einzulesen anstatt immer nur das zu tun was andere sagen damit du auch verstehst was du dort tust. Und dann spielst du eben einfach mal rum und probierst Dinge aus. Die Basis hast du nun.
 
29 Dec 2017
243
26
#12
Du hast doch hier selbst bestätigt dass es funktioniert. Wenn jetzt eine Seite doch Werbung anzeigt deckt deine Liste es wohl nicht ab.

Empfehle dir auch dich einfach mal in das Thema einzulesen anstatt immer nur das zu tun was andere sagen damit du auch verstehst was du dort tust. Und dann spielst du eben einfach mal rum und probierst Dinge aus. Die Basis hast du nun.
Ja das war, weil ich noch Browser mit uBlock Origin hatte. Jetzt wo ich das aus habe, zeigt er mir auch wieder Werbungen an. Keine Ahnung wieso das jetzt nicht geht, ist alles richtig eingestellt und selbst wenn ich im PiHole Seiten seperat blocken lasse kann ich trotzdem noch auf die Seiten zugreifen.
 
29 Dec 2017
243
26
#13
Gut schade, es geht einfach nicht. Habe alles so eingestellt wie du mir etliche Videos jetzt angeschaut. Wenn ich im PiHole Seiten auf die Blacklist setze komme ich trotzdem noch mit jedem Gerät drauf. Vielleicht liegts auch an Unitymedia das die da irgendwas blockieren oder so.
 
25 Apr 2015
821
317
#14
Das ist DNS da wird nichts blockiert.
Hast du deinen PiHole denn in deinen Geräten als DNS Server angegeben?
 
29 Dec 2017
243
26
#15
Nein, ich habe das so gemacht wie oben.
Aber selbst wenn ich den DNS Server vom PiHole in meinen Geräten eingebe, bringt das nichts.

So habe ich alles angeschlossen:
FritzBox 6591 Cable -> Fritz Repeater 1750 am Repeater ist angeschlossen Switch per LAN vom Repeater auf den Raspberry/Meinen PC.

DNS Einstellungen von der FritzBox: 8.8.8.8 / 8.8.4.4
DNS Einstellungen PiHole: Meine FritzBox IP als Primärer DNS als Alternativer: Google DNS


 
29 Dec 2017
243
26
#19
Nimm mal im PiHole die Haken bei dem Google DNS Raus...
Habe ich gemacht, immer noch so.
Ich weiß nicht wieso du dort Google anhakst und wieso hinter deiner IP der FB noch #53 angegeben ist.
Und das #53 habe ich nicht eingetragen, das wird automatisch so eingetragen. Ich gebe nur "192.168.178.1" ein, nachdem ich dann auf Save klicke steht das dahinter.